Ubuntu iTOps Tube

advertisement center

Sunday, May 6, 2012

[ubuntu] 12.04 upgrade issues - python-uno conflicts with libreoffice-core

Hello,



I upgraded from 11.10 to 12.04 a week. During the upgrade, there were some failures around libreoffice upgrade. Since then, looks like "The package system is broken". Everytime I try to install latest updates, I get the following message:




Code:


The package system is broken



Check if you are using third party repositories. If so disable them, since they are a common source of problems.

Furthermore run the following command in a Terminal: apt-get install -f



Details



The following packages have unmet dependencies:



libreoffice-base-core: Depends: libreoffice-core (= 1:3.5.2-2ubuntu1) but 1:3.4.4-0ubuntu1 is installed

libreoffice-calc: Depends: libreoffice-core (= 1:3.5.2-2ubuntu1) but 1:3.4.4-0ubuntu1 is installed

                  Depends: libreoffice-base-core (= 1:3.5.2-2ubuntu1) but 1:3.5.2-2ubuntu1 is installed

                  Depends: libgcc1 (>= 1:4.1.1) but 1:4.6.3-1ubuntu5 is installed

libreoffice-common: Depends: libreoffice-style but it is a virtual package

libreoffice-draw: Depends: libreoffice-core (= 1:3.5.2-2ubuntu1) but 1:3.4.4-0ubuntu1 is installed

                  Depends: libgcc1 (>= 1:4.1.1) but 1:4.6.3-1ubuntu5 is installed

libreoffice-gnome: Depends: libreoffice-core (= 1:3.5.2-2ubuntu1) but 1:3.4.4-0ubuntu1 is installed

                  Depends: libgcc1 (>= 1:4.1.1) but 1:4.6.3-1ubuntu5 is installed

libreoffice-gtk: Depends: libreoffice-core (= 1:3.5.2-2ubuntu1) but 1:3.4.4-0ubuntu1 is installed

                Depends: libgcc1 (>= 1:4.1.1) but 1:4.6.3-1ubuntu5 is installed

libreoffice-impress: Depends: libreoffice-core (= 1:3.5.2-2ubuntu1) but 1:3.4.4-0ubuntu1 is installed

                    Depends: libreoffice-draw (= 1:3.5.2-2ubuntu1) but 1:3.5.2-2ubuntu1 is installed

                    Depends: libgcc1 (>= 1:4.1.1) but 1:4.6.3-1ubuntu5 is installed

libreoffice-math: Depends: libreoffice-core (= 1:3.5.2-2ubuntu1) but 1:3.4.4-0ubuntu1 is installed

                  Depends: libgcc1 (>= 1:4.1.1) but 1:4.6.3-1ubuntu5 is installed

libreoffice-writer: Depends: libreoffice-core (= 1:3.5.2-2ubuntu1) but 1:3.4.4-0ubuntu1 is installed

                    Depends: libreoffice-base-core (= 1:3.5.2-2ubuntu1) but 1:3.5.2-2ubuntu1 is installed

                    Depends: libgcc1 (>= 1:4.1.1) but 1:4.6.3-1ubuntu5 is installed


On running "sudo apt-get clean" followed by "sudo apt-get -f install", I get:




Code:


Reading package lists... Done

Building dependency tree     

Reading state information... Done

Correcting dependencies... Done

The following packages were automatically installed and are no longer required:

  libx264-116 libqt4-qt3support libaccess-bridge-java-jni libaccess-bridge-java libmusicbrainz4c2a openoffice.org-common libaudiofile0 libiso9660-7 libid3tag0 libreoffice-l10n-common libmatroska4

Use 'apt-get autoremove' to remove them.

The following extra packages will be installed:

  libreoffice-core python-uno

The following packages will be upgraded:

  libreoffice-core python-uno

2 upgraded, 0 newly installed, 0 to remove and 62 not upgraded.

12 not fully installed or removed.

Need to get 37.4 MB of archives.

After this operation, 3,497 kB disk space will be freed.

Do you want to continue [Y/n]? Y

Get:1 http://us.archive.ubuntu.com/ubuntu/ precise/main python-uno i386 1:3.5.2-2ubuntu1 [155 kB]

Get:2 http://us.archive.ubuntu.com/ubuntu/ precise/main libreoffice-core i386 1:3.5.2-2ubuntu1 [37.2 MB]

Fetched 37.4 MB in 34s (1,077 kB/s)                                                                                                                                                                               

  python-uno:i386 conflicts with libreoffice-core:i386

dpkg: regarding .../python-uno_1%3a3.5.2-2ubuntu1_i386.deb containing python-uno:

 python-uno conflicts with libreoffice-core (<< 1:3.5~)

  libreoffice-core (version 1:3.4.4-0ubuntu1) is present and broken due to postinst failure.

dpkg: error processing /var/cache/apt/archives/python-uno_1%3a3.5.2-2ubuntu1_i386.deb (--unpack):

 conflicting packages - not installing python-uno

Errors were encountered while processing:

 /var/cache/apt/archives/python-uno_1%3a3.5.2-2ubuntu1_i386.deb

E: Sub-process /usr/bin/dpkg returned an error code (1)


On running "sudo apt-get autoremove -f" I get:




Code:


Reading package lists... Done

Building dependency tree     

Reading state information... Done

Correcting dependencies... Done

The following extra packages will be installed:

  libreoffice-core python-uno

The following packages will be REMOVED:

  libaccess-bridge-java libaccess-bridge-java-jni libaudiofile0 libid3tag0 libiso9660-7 libmatroska4 libmusicbrainz4c2a libqt4-qt3support libreoffice-l10n-common libx264-116 openoffice.org-common

The following packages will be upgraded:

  libreoffice-core python-uno

2 upgraded, 0 newly installed, 11 to remove and 61 not upgraded.

12 not fully installed or removed.

Need to get 0 B/37.4 MB of archives.

After this operation, 11.7 MB disk space will be freed.

Do you want to continue [Y/n]? Y

  python-uno:i386 conflicts with libreoffice-core:i386

dpkg: regarding .../python-uno_1%3a3.5.2-2ubuntu1_i386.deb containing python-uno:

 python-uno conflicts with libreoffice-core (<< 1:3.5~)

  libreoffice-core (version 1:3.4.4-0ubuntu1) is present and broken due to postinst failure.

dpkg: error processing /var/cache/apt/archives/python-uno_1%3a3.5.2-2ubuntu1_i386.deb (--unpack):

 conflicting packages - not installing python-uno

Errors were encountered while processing:

 /var/cache/apt/archives/python-uno_1%3a3.5.2-2ubuntu1_i386.deb

E: Sub-process /usr/bin/dpkg returned an error code (1)


Any help will be greatly appreciated.



Thanks in advance!